Search found 18 matches

by Asbjørn_Djupdal
Thu Jan 31, 2019 12:20 pm
Forum: FAQ about Tulipp Development Platform
Topic: How to export the power measurement results
Replies: 11
Views: 216

Re: How to export the power measurement results

The sample period is now in seconds, so if you want 1 second you should put a 1 in the box.
by Asbjørn_Djupdal
Wed Jan 30, 2019 2:20 pm
Forum: FAQ about Tulipp Development Platform
Topic: How to export the power measurement results
Replies: 11
Views: 216

Re: How to export the power measurement results

Export feature added. You find it in the "File" menu.
by Asbjørn_Djupdal
Wed Jan 30, 2019 12:21 pm
Forum: FAQ about Tulipp Development Platform
Topic: How to export the power measurement results
Replies: 11
Views: 216

Re: How to export the power measurement results

Good, that looks like ok, and due to I running the Linux system in the board now, so the elf and bitstream don't upload by the LynSyn board that loading by boot file in the board. The collected power data directly from the sensor, maybe, the function data can't be collected now? However, you can ad...
by Asbjørn_Djupdal
Wed Jan 30, 2019 12:09 pm
Forum: FAQ about Tulipp Development Platform
Topic: How to export the power measurement results
Replies: 11
Views: 216

Re: How to export the power measurement results

Thanks. I'll probably do this before the end of the week.

I have added this feature request to the github issue tracker:
https://github.com/tulipp-eu/sthem/issues/10

Further status about the development of this feature will be given there.
by Asbjørn_Djupdal
Wed Jan 30, 2019 10:40 am
Forum: FAQ about Tulipp Development Platform
Topic: How to export the power measurement results
Replies: 11
Views: 216

Re: How to export the power measurement results

I wanted a suggestion for how you want the data file formatted. One example could be like this:

=== test.csv start here ===
Time;Power;Function name
0.0001;6.2;main()
0.0003;7.2;main()
0.0012;5.5;otherFunction()
=== test.csv end here ===

Would this be OK?
by Asbjørn_Djupdal
Wed Jan 30, 2019 7:29 am
Forum: FAQ about Tulipp Development Platform
Topic: How to export the power measurement results
Replies: 11
Views: 216

Re: How to export the power measurement results

Hi The data is stored in an sqlite database file (profile.db3). You can use the sqlitebrowser to access the data. However, I should probably make an export function that exports to a csv file. If you provide me with a description (or example) of how you would like to have the data exported, I will m...
by Asbjørn_Djupdal
Thu Jan 03, 2019 3:25 pm
Forum: FAQ about Tulipp Development Platform
Topic: Assertion `success' failed after Profiling with LynSyn
Replies: 3
Views: 427

Re: Assertion `success' failed after Profiling with LynSyn

If you do not want to recompile everything, it should be sufficient to just delete the profile.db3 file within the ~/.tulipp/<project_name>/ directory.
by Asbjørn_Djupdal
Thu Jan 03, 2019 3:23 pm
Forum: FAQ about Tulipp Development Platform
Topic: Assertion `success' failed after Profiling with LynSyn
Replies: 3
Views: 427

Re: Assertion `success' failed after Profiling with LynSyn

This should of course not happen. Is there any chance that you have tried the analysis tool several versions ago? If so, there could be a problem with your measurement database having the wrong schema. If that is the case, please enter the following command:

$ rm -rf ~/.tulipp

Then try again.
by Asbjørn_Djupdal
Thu Jan 03, 2019 7:32 am
Forum: FAQ about Tulipp Development Platform
Topic: Analysis utility issue on "Build CFG"
Replies: 5
Views: 79

Re: Analysis utility issue on "Build CFG"

Strange. Seems like your c++ compiler does not accept c++11. I have now added the c++11 flag to the Makefile, hopefully that will fix it.
by Asbjørn_Djupdal
Wed Jan 02, 2019 8:50 am
Forum: FAQ about Tulipp Development Platform
Topic: Analysis utility issue on "Build CFG"
Replies: 5
Views: 79

Re: Analysis utility issue on "Build CFG"

I am finally back from christmas vacation.

You should not need to use absolute paths, this sounds like a bug. I did fix something similar before christmas, but if you pulled the latest version from git shortly before you posted, you should have the new version.

I will look into it.

Go to advanced search